Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Let's encrypt Renew License

mjflintmjflint Member
edited April 2019 in General Discussions
Hello Community,

I originally set up a Let's ecnrypt certificate by referencing the following tutorial:

This worked really well and I was able to have a working DirectAdmin panel with Let's encrypt SSL.  Today my original 90 day certificate has expired.  

I planned on executing the following commands on my Centos 6 VPS with DirectAdmin

cd /usr/local/directadmin/scripts
./ request 4096

After executing the listed commands above with SSH I receive the following:

[root@vps scripts]# ./ request 4096
Setting up certificate for a hostname:
Getting challenge for from acme-server...
Waiting for domain verification...
Challenge is valid.
Getting challenge for from acme-server...
Error: is not reachable. Aborting the script.
dig output for
Please make sure /.well-known alias is setup in WWW server.

It seems that I have to make sure that the alias is setup in WWW server.  I searched for information and followed the support guide on DirectAdmin's support forum:

I was able to successfully execute the acme challenge test and view the 'text' message in my web browser Chrome.  

I would like to know if anyone is experiencing similar problems while working within the Centos 6 and Direct Admin environment.  I also have noticed that this 'alias error' is currently affecting the automatic license update of DirectAdmin.  Now I have to manually update it before it expires a the end of the scheduled thirty day period.  

I thank all of you for time and assistance.

Best regards,



  • mjflintmjflint Member
    edited June 2017
    Hello Community,

    After searching out more information and receiving ideas from other administrators I was guided to the importance of checking the following file on my server:


    I was told that there were bad url references and this was causing the error.  Therefore, I deleted all bad url reference and left my hostname domain as the only reference.  After executing the script above to  renew the license everything worked flawlessly and I now have a secure SSL environment within DirectAdmin.  I hope this information serves for anyone else that might run into this situation.  

    Best regards,

Sign In or Register to comment.


Learn how to install a web and database server, email, FTP client or other applications. Discover and share information on server security or optimization recommendations.
Feel free to join our constantly expanding community, participate in discussions, strengthen your knowledge on Linux and Windows server management!
© 2013 - 2024 Time4VPS. All rights reserved.

Get In Touch