Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Restore Network Interface via Web Console

JustinJustin Member
edited May 2017 in Various Tutorials


It's not so uncommon to lost network access to the server via SSH (e.g. due to accidentally misconfigured VPS or etc.). Knowing this we offer alternative method to connect to the server in extra cases like this - Web Console. This tutorial will help you to pin point causes of the issue and restore accessibility via SSH.

Connecting via Web Console

You can access Web Console via Clients Area:

1. Press "Mange" in the end of the line of server you want to connect.
2. Then press ">_Console" button.
3. Choose for how long do you want to access console and press "Continue".
4. After few minutes you will get link to the Web Console. Enter your login details and login.

More information (with pictures) about our Client Area can be found here.

Possible Issue # 1

First of all yous should check if network interface is up. Run command:
There should be three interfaces: local, venet0 and it's virtual interface venet0:0. It should look something like this:

Note: In black squares you should see IP of your server.

If you see that network interface is not loaded (do not see venet0 or/and venet0:0) ...


First of all you can try to restart it with this command:
/etc/sysconfig/network-scripts/ifup venet0:0
If, for some reason, above method fail, you should add and start network interface manually by executing these commands:
ip addr add dev venet0 IP_of_your_server/32
ifconfig venet0 up
route add default dev venet0
Note: In the place of IP_of_your_server you should write IP of your server.


After above steps are executed you should once again check network interface with command:
If everything seems fine and network interface is up try to ping for example to Google's IP:
If it's pinging, hooray, your server once again have network access. Try to connect to the server via SSH.

Possible Issue # 2

However if, despite network interface is up, you are still not able to connect to the server via SSH you should check if SSH is running:
netstat -nltp | grep sshd
If you did not got any answer it means that SSH is not started.


In this case simply start ssh daemon with commands:

On Ubuntu/Debian systems:
service ssh start
On CentOS systems:
systemctl start sshd.service


Once again run:
netstat -nltp | grep sshd
This time you should got result like this:

Note: As in this example standard SSH port is 22, so connections via SSH should be done through port 22. However if you see other port you need to connect through port you see. For security reasons it's recommended to use other then standard port. SSH port can be change in file:
nano /etc/ssh/sshd_config 
Change port number of the line:

Port 22

To whatever not taken port in range 1 to 65535.


To test if it worked simply try to connect via SSH again.

If you still have problems accessing your VPS via SSH, open support ticket and we will help you to resolve the problem.
Sign In or Register to comment.

Learn how to install a web and database server, email, FTP client or other applications. Discover and share information on server security or optimization recommendations.
Feel free to join our constantly expanding community, participate in discussions, strengthen your knowledge on Linux and Windows server management!
© 2013 - 2021 Time4VPS. All rights reserved.

Get In Touch